Canonical publica hoja de ruta de compatibilidad de Ubuntu con todos los modelos de Raspberry Pi

La última versión del sistema operativo de Canonical, Ubuntu Server 19.10, es compatible con el mini ordenador Raspberry Pi 4, que es la última versión de esta placa de la Fundación Raspberry Pi y en un futuro, este sistema operativo será compatible con todas las placas Raspberry Pi.

Esto si bien se debe al trabajo de Canonical, también en gran parte se debe a que la nueva Raspberry Pi 4 integra un chip más rápido con un procesador que utiliza la arquitectura Cortex-A72, con cuatro núcleos 64-bit ARMv8 a 1.5GHz.

Además la placa Raspberry Pi 4 modelo B incluye diferentes opciones de memoria RAM con 1GB, 2GB y la mayor con 4GB.  Ahora si bien tienen pensado ofrecer soporte para la placa con 4GB de memoria RAM, es esta primera etapa Ubuntu Server 19.10 es compatible solo con las versiones de 1GB y 2GB.

Raspberry PI 4
Imagen Raspberry Pi Organization

El problema que tuvo Canonical para poder ofrecer soporte con la placa de 4GB es que debido a un error del Kernel, los puertos USB no son compatibles de fábrica con la imagen oficial de arm64 en la versión de 4GB.

Lo bueno de esto es que ya están probando los arreglos a este problema y Canonical piensa que lanzarán la actualización en pocas semanas más para que la versión de Raspberry Pi 4 de 4GB sea compatible con Ubuntu Server 19.10.

Mientras tanto los desarrolladores que no quieran esperar a los arreglos y quieran trabajar con esta nueva versión del sistema operativo y la placa de 4GB pueden hacerlo con un arreglo manual que activa USB .  Solo tienen que editar el fichero /boot/firmware/usercfg.txt para limitar la memoria RAM a 3GB:  total_mem=3072

De acuerdo a Canonical están “respaldando la Raspberry Pi 4 para que los desarrolladores tengan acceso a una placa de bajo costo, lo suficientemente potente como para consolidar las cargas de trabajo informáticas en el borde“.

La hoja de ruta muestra que la próxima etapa luego de la actualización para hacer compatible a la placa de 4GB, será la compatibilidad de Ubuntu Server 18.4 y luego trabajaran para que también las 3 versiones de Raspberry Pi 4 (1,2 y 4 GB) sean compatibles con Ubuntu Core.

Ilustración Canonical Ubuntu Blog

Fuente | Canonical Ubuntu Blog

Siguenos por Twitter a través de @Geeksroom y no te pierdas todas las noticias, cursos gratuitos y demás artículos. También puedes seguirnos a través de nuestro canal de Youtube para ver nuestros vídeos y a través de Instagram para ver nuestras imágenes!